Windows Management Framework (WMF) 3.0 on Exchange 2007-2010 is not supported YET!

Did you install the optional updates KB2506146 or KB2506143 to try out (or not) Windows PowerShell 3.0?

I just noticed the blog post at MS Exchange Team Blog about WMF 3.0 on Exchange 2007-2010 and wanted to share this. I have been seeing posts about this at forums. Per The Exchange Team Blog:

Windows Management Framework 3.0 (specifically PowerShell 3.0) is not yet supported on any version of Exchange except Exchange Server 2013 (which requires it)…

and if you happen to have installed it, you may have broken installation of updates:

  • If rollup is installed through Microsoft Update, the installation might error with error code of 80070643
  • If rollup is installed from a download, the error displayed is “Setup ended prematurely because of an error."
  • In both cases, event log might show the error with an error code of “1603

Be careful, spread the word…


Some of the symptoms are included in this post

UPDATE: 12/17/2012

Apparently WMF 3.0 also breaks SCVMM agents in HyperV:

Managing Hyper-V hosts using Virtual Machine Manager fails with Error: 0x8033803b after installing WMF 3.0.

Please visit the following link to resolve the issue (uninstall/restart/winrm qc/restart)

http://support.microsoft.com/kb/2795043?wa=wsignin1.0 


UPDATE: 12/20/2012

Per Powershell Blog post, the download is now moved to Microsoft Download center. Known Compatibility Issues are:

Windows Management Framework 3.0 (WMF 3.0) is not currently compatible with the following applications.

-         System Center 2012 Configuration Manager

http://support.microsoft.com/kb/2796086  (Configuration Manager Management Points collocated with clients fail after installing Windows Management Framework 3.0 and running Client Health Evaluation)

-         System Center Virtual Machine Manager

http://support.microsoft.com/kb/2795043 (Managing Hyper-V hosts using Virtual Machine Manager fails with Error: 0x8033803b after installing WMF 3.0)

-         Microsoft Exchange Server 2007 and Microsoft Exchange Server 2010

http://blogs.technet.com/b/exchange/archive/2012/12/14/windows-management-framework-3-0-on-exchange-2007-and-exchange-2010.aspx (Windows Management Framework 3.0 on Exchange 2007 and Exchange 2010)

-         Microsoft SharePoint 2010

http://connect.microsoft.com/PowerShell/feedback/details/746908/powershell-3-0-and-sharepoint-2010  (Windows PowerShell 3.0 and SharePoint 2010)

-         Windows Small Business Server 2008 and Windows Small Business Server 2011

http://blogs.technet.com/b/sbs/archive/2012/12/15/windows-management-framework-3-0-applicability-on-windows-small-business-server-2008-2011-standard.aspx  (Windows Management Framework 3.0 applicability on Windows Small Business Server 2008/2011 Standard)

Systems that are running the above server applications should not run Windows Management Framework 3.0 at this time

Bulent Tolu

Bulent Tolu

Bulent is an IT professional with Master's in MIS and 10-years of experience in broad range of Information Technologies. He is exposed to engineering/architecting, implementation/integration, and administration of various high-available IT systems and infrastructure. He has a passion to continually research, test and evaluate new technologies and follow industry best practices to secure and optimize IT systems. Currently, he lives in Istanbul and works as a Sr. Cloud Computing and Virtualization Consultant. He has a diverse knowledge and interest in Virtualization and Cloud Computing.

:: VMware Certified Advanced Professional 5
Data Center Administration (VCAP5-DCA)
Data Center Design (VCAP-DCD)
:: VTSP (VMware Certified Technical Sales Professional 5)
:: MCSE(Microsoft Certified Solutions Expert) – Private Cloud 2012
:: CCEE(Citrix Certified Enterprise Engineer)
Bulent ToluBulent ToluBulent ToluBulent Tolu Bulent Tolu
Bulent Tolu

Leave a Reply